Catatan Belajar

welcome

Beruntung sekali seorang anak muda meninggal dgn brjuta-juta pahala, Malang kali seorang manusia yg meninggal dgn secuil pahala, Berilah hamba kaya akan ridhoMu ya Allah.

Thursday, April 28, 2011

Load BALANCE MIKROTIK

3 Line
Setting PPPoE Client
/interface pppoe-client
add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" \
dial-on-demand=no disabled=no interface=Speedy-1 max-mru=1480 max-mtu=1480 \
mrru=disabled name="PPPoE-1" user="******@telkom.net" password="***" profile=default \
service-name="" use-peer-dns=no user="***"

add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" \
dial-on-demand=no disabled=no interface=Speedy-2 max-mru=1480 max-mtu=1480 \
mrru=disabled name="PPPoE-2" user="******@telkom.net" password="***" profile=default \
service-name="" use-peer-dns=no user="***"

add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" \
dial-on-demand=no disabled=no interface=Speedy-3 max-mru=1480 max-mtu=1480 \
mrru=disabled name="PPPoE-3" user="******@telkom.net" password="***" profile=default \
service-name="" use-peer-dns=no user="***"

Mangle LoadBalance
/ip firewall mangle
add action=mark-connection chain=input comment=\
"NEW Load Balance" connection-state=new \
disabled=no in-interface=Speedy-1 new-connection-mark=ADSL-1 \
passthrough=yes
add action=mark-connection chain=input comment="" connection-state=new \
disabled=no in-interface=Speedy-2 new-connection-mark=ADSL-2 \
passthrough=yes
add action=mark-connection chain=input comment="" connection-state=new \
disabled=no in-interface=Speedy-3 new-connection-mark=ADSL-3 \
passthrough=yes

add action=mark-routing chain=output comment="" connection-mark=ADSL-1 \
disabled=no new-routing-mark=jalur-1 passthrough=no
add action=mark-routing chain=output comment="" connection-mark=ADSL-2 \
disabled=no new-routing-mark=jalur-2 passthrough=no
add action=mark-routing chain=output comment="" connection-mark=ADSL-3 \
disabled=no new-routing-mark=jalur-3 passthrough=no

add action=mark-connection chain=prerouting comment="" disabled=no \
dst-address-type=!local in-interface=Lokal new-connection-mark=\
ADSL-1 passthrough=yes per-connection-classifier=\
both-addresses-and-ports:3/0
add action=mark-connection chain=prerouting comment="" disabled=no \
dst-address-type=!local in-interface=Lokal new-connection-mark=\
ADSL-2 passthrough=yes per-connection-classifier=\
both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting comment="" disabled=no \
dst-address-type=!local in-interface=Lokal new-connection-mark=\
ADSL-3 passthrough=yes per-connection-classifier=\
both-addresses-and-ports:3/2



Konfigurasi NAT

Opsi 1:
/ip firewall nat
add chain=srcnat action=masquerade out-interface=PPPoE-1 comment="" disabled=no
add chain=srcnat action=masquerade out-interface=PPPoE-2 comment="" disabled=no
add chain=srcnat action=masquerade out-interface=PPPoE-3 comment="" disabled=no

Opsi 2:
/ip firewall nat
add chain=srcnat action=masquerade src-address="IP Lokal anda"


Konfigurasi Route
/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-1 \
routing-mark=Jalur-1
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-2 \
routing-mark=Jalur-2
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-3 \
routing-mark=Jalur-3

add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-3
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-1
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-2
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-1




Atau juga
2 LINE
/interface pppoe-client
add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" \
dial-on-demand=no disabled=no interface=Speedy-1 max-mru=1480 max-mtu=1480 \
mrru=disabled name="******@telkom.net" password="***" profile=default \
service-name="" use-peer-dns=no user="***"

add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" \
dial-on-demand=no disabled=no interface=Speedy-2 max-mru=1480 max-mtu=1480 \
mrru=disabled name="******@telkom.net" password="***" profile=default \
service-name="" use-peer-dns=no user="***"


/ip firewall mangle
add action=mark-connection chain=input comment=\
"NEW Load Balance" connection-state=new \
disabled=no in-interface=Speedy-1 new-connection-mark=ADSL-1 \
passthrough=yes
add action=mark-connection chain=input comment="" connection-state=new \
disabled=no in-interface=Speedy-2 new-connection-mark=ADSL-2 \
passthrough=yes

/ip firewall mangle
add action=mark-connection chain=input comment=\
"NEW Load Balance" connection-state=new \
disabled=no in-interface=Speedy-1 new-connection-mark=ADSL-1 \
passthrough=yes
add action=mark-connection chain=input comment="" connection-state=new \
disabled=no in-interface=Speedy-2 new-connection-mark=ADSL-2 \
passthrough=yes

add action=mark-connection chain=prerouting comment="" disabled=no \
dst-address-type=!local in-interface=Lokal new-connection-mark=\
ADSL-1 passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting comment="" disabled=no \
dst-address-type=!local in-interface=Lokal new-connection-mark=\
ADSL-2 passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/1

/ip firewall nat
add chain=srcnat action=masquerade out-interface=PPPoE-1 comment="" disabled=no
add chain=srcnat action=masquerade out-interface=PPPoE-2 comment="" disabled=no

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-1 \
routing-mark=ADSL-1
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-2 \
routing-mark=ADSL-2
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-2
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=PPPoE-1
add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=PPPoE-2


kutipan dari mikrotik

No comments:

Post a Comment